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ArcGIS Tutorial: 

Adding Coordinate Data 

Introduction  

 
This tutorial describes how to import point data stored in a table as x y coordinates into a GIS 
and display it on a map. A common example is data collected with a global positioning systems 

(GPS) unit. This tutorial is not intended to provide instruction in GPS mapping or using a GPS.  
Those interested in learning more about these topics should consider enrolling in CSS 465, 

Global Positioning System course. 
 
In this exercise, we’ll take field-collected data downloaded from a GPS and edit it so it can be 

added to ArcMap.  We’ll preview and re-project some base map data (using ArcCatalog) so it is 
in the same projection as our point data.  We’ll use ArcMap to add our data to the base map, and 

edit it to produce a final map.  The field-collected data are the coordinates for the locations of 
trees around the Cornell campus that were photographed and included in a photography exhibit 
by Matthew Pace (’07) at Mann Library.  The base map data come from the City of Ithaca. 

Copy Data from Classroom Files Server 

All the data for this workshop are located on the Classroom Files server (accessible from any 

classroom computer -use the desktop shortcut to get there).  It’s important to have no spaces or 
special characters anywhere in the path directories of your data files.  For this exercise,  

 Open the Classroom Files server, and navigate to the \GIS\ArcGIS_2\ directory 

 Copy the entire GPS folder (17 files in all) to C:\WorkSpace\ on your computer. 

UPart I. Data Collection and Editing 

 
GPS configuration: It is important that datum and coordinate system of your data and the base 

map data are the same.  Select a coordinate system and datum appropriate to your project, and 
make sure the GPS unit is set to collect data in your chosen coordinate system and datum.  If 
you’re using longitude and latitude (x y), these should be expressed as decimal degrees (DD) 

rather than degrees, minutes and seconds (DMS).  You can convert DMS to DD later if you do 
not select DD before collecting data.  Data for this exercise were collected in UTM (zone 18n), 

and the datum is NAD83. More information on coordinate systems can be found in ArcGIS 
Desktop Help. 
 

If you use one of Mann Library’s GPS units available for loan, other easier options may exist for 
converting and importing coordinate data directly from the unit. Information can be found on the 
GPS equipment page at http://mannlib.cornell.edu/equipment-software/equipment- loans/gps.  

Mann Library computers have software that can convert data directly to a shapefile, which can 
be used in ArcMap.  Because users may obtain coordinate data from other units or from existing 

files, this tutorial takes a more generic approach and assumes that the data are in a text file or 
spreadsheet format and require editing to import into ArcMap. 

http://mannlib.cornell.edu/equipment-software/equipment-loans/gps
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Editing tabular data 

 

Here are some general tips on formatting a table of GPS coordinates. 
 

 If you’re working in latitude and longitude, in the northern and western hemispheres, 
north latitudes are positive, and west longitudes are negative. You may need to edit 

values accordingly. 

 If your latitude and longitude coordinates are in DM (degrees, minutes) or DMS (degrees, 
minutes, seconds), convert to decimal degrees (DD). 

o For DMS: DD = degrees + minutes/60 + seconds/3600 
o For DM:  DD = degrees + minutes/60 

 Data (i.e. coordinate) fields or columns should have a numeric format (make sure to 
allow an adequate number of decimal places if needed). 

 Text fields or columns should have a text format. 

 Shorten column headings to 10 characters or less, remove spaces and special characters 

and do not begin column headings with numbers. 

 If you have problems importing .xls files, save tabular data in either .csv or .dbf format to 

import into ArcMap. 
 

Exercise 1 

In this part of the workshop, you’ll edit a text file that includes downloaded GPS data, so it can 

be added to ArcMap. This file contains the data output from a Garmin GPS using MapSource 
(Garmin’s software distributed with their GPS units) in columns A-S.  In preparing this 

workshop, we added some additional information in columns T-W specific to our dataset.   
 

1. From the Start menu, open Microsoft Excel  

 
2. Open the C:\WorkSpace\GPS\TreeData.txt file. Select All Files in the lower right if 

you don’t see it from the Open window.  
 

A Text Import Wizard Dialogue box should open.  

 
3. Make sure Delimited is selected, 

and  
 

4. Start import at row 4 (where 

headers begin).  
 

5. Click Finish. 
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Notice that the UTM Zone (18) and X and Y coordinate data are in one column (Position) in this 
spreadsheet.  To parse the coordinate data into separate columns:  
 

1. Click the top of the Position column (E) to highlight 
 

2. From the Data tab, select Text to Columns 

 

3. Select Delimited File Type 
 

4. Click Next 

 
5. Check the box labeled Space.  

Excel inserts dividers in 
between all the columns.  The 
dialog box should look like 

this: 
 

 
6. Click Finish, and Yes to 

replace contents of destination 

cells.  Your four separated 
columns now are UTM zone, a 

column of T’s, and two more 
columns of numbers.  
  

 
7. Rename the column containing 6-digit numbers beginning with 37 (X, or Longitude 

coordinates) to UTM_X.  Rename the column containing 7-digit numbers beginning 

with 47 UTM_Y. 
 

8. Delete any other extraneous columns. Select the Home tab, Highlight the rows or 
columns to delete then click Delete > Delete Sheet Columns.  

 

9. Rename remaining headers with meaningful names of 10 characters or less, no spaces or 
special characters. Your table should look something like this: 

 
 

Check and change the formats of data and text columns as 
needed.  For both the UTM_X and UTM_Y columns, 
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10. Highlight each column, right click and select Format > Cells, and set format to Number 

with 0 decimal places. Set the format of all the other columns to Text.  

 
11. Making sure you have no columns or rows highlighted, save your file to your 

WorkSpace directory as a Excel 97-2003 Workbook (.xls) file by choosing File > Save 

As… from the main menu and selecting the file type from the pull-down menu.  
 

12. Quit Excel.  You now have a table you can import into ArcMap. 
 

 
UPart III. Preparing a Basemap and Importing Data U  
 

In this section we will preview and check the projection of our basemap data, reproject it to 
match our GPS data, and add our data to the map.   

 
Section 1: Preview and reproject base map data in ArcCatalog 

 

1. Start ArcCatalog (go to START>All Programs>ArcGIS>ArcCatalog). 
 

2. In the table of contents pane (left pane), navigate to your C:\WorkSpace\ folder and 
click on building.shp so it’s highlighted. 
 

3. You can see what the 
data looks like by 

selecting the Preview 
tab at the top of the 
right pane (select 

Geography on bottom 
drop down menu if 

needed). 
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4. To check the building shapefile 

coordinate system:  

 Right click the buildings.shp file 

in the left pane,  

 Select Properties,  

 Select the XY Coordinate 

System tab.  Note that the 
projection for this data (State 

Plane) differs from the one we 
used to collect our GPS data 

(UTM).  The datum for this data 
set is the same as the one we used 
to collect GPS data: North 

American Datum of 1983, or 
NAD 83. Click OK. 

 

5. Check the projection and datum of 
the other datasets (roads.shp and 

waterway.shp).  They should be the 
same as the building.shp file.   

 
 
We’ll use the tools in ArcToolbox to reproject the basemap datasets.  If not already open, start 

ArcToolbox by clicking on the red toolbox icon  in the toolbar of ArcCatalog.  This will open 
ArcToolbox as a new window. If not already docked to left side, double click top of ArcToolbox 

window to dock 
 

6. In the ArcToolbox pane, 

expand the Data 

Management Tools by 

clicking on the plus sign.  
Then expand Projections 

and Transformations > 

Feature, and select 
(double-click) Batch 

Project.  
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7. In the dialog box, for the Input Feature Class or Dataset, click folder icon and navigate 
to the C:\WorkSpace\GPS folder and select (holding down control key) the files you 

want to reproject (building.shp, roads.shp and waterway.shp). Click Add. 
 

8. Select the C:\WorkSpace\GPS folder as the Output Workspace.  
 

9. Click on the selector icon  to select the 

Output Coordinate System.  In the Spatial 

Reference Properties dialog box, click on the 

Select… button, and make the following 
selections: Projected coordinate systems> 
UTM>NAD 1983> NAD 1983 UTM Zone 

18N.prj.  Then click Add.  Your selections 
should now appear in the window of the dialog 

box.   
 

 

10. Click OK to close, and OK to start the 
projection process.  You should see a status 

message.   
 

11. If you want, check the projection information 

for your new UTM projection datasets (auto-
named building_1.shp, Roads_1.shp and 

WATERWAY_1.shp in ArcCatalog) by 
selecting the Catalog Tree tab in lower left 

 
 

12. Quit ArcCatalog. 
 

Section 2: Add Spatial Data to ArcMap 

 

1. Start ArcMap (go to START>Programs>ArcGIS>ArcMap). Click Cancel or close the 

Getting Started window.  
2. Maximize the window and dock (drag) any toolbars so they are out of the way. 

 

3. To add your spatial data to the map view, click the Add Data button .  Navigate to 

your C:\WorkSpace folder and select your reprojected files (ones with trailing 
“_1.shp” suffix) (hold down the Ctrl key to select more than one). Once highlighted,   

Click Add. 
 

4. Add your TreeData.xls file of GPS coordinates the same way, selecting the TreeData$ 

worksheet. 
 

5. Save and name your map in the GPS folder. 

6. Zoom in to the Cornell area using the magnifying glass tool: . 
 



ArcGIS Tutorial: Adding Coordinate Data (v10.0) – 2011-10-21 – p.7 
 

To add your coordinates to the map,  
7. Right click the TreeData$ layer in the Table of 

Content, select Display XY Data.  Set the X 

Field to UTM_X and set the Y Field to 

UTM_Y.   
 

8. The coordinate system should be correct for 

this exercise.  
 

 
9. Click OK to close the dialog.  The Add XY 

dialog box should look like this:  

 
 

10. Click OK to finish.   
 

11. You will see a message stating the Table Does 

Not Have an Object_ID field. For this exercise 
we will be exporting to a shapefile, so Click 

OK to finish.   
 

12. Save your map. 

 
 

 
Notice your GPS points are now displayed on the basemap as TreeData$ Events.   
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While you’ve added the points to the map, you haven’t created an actual data file that you can 
use in ArcMap the way you can use the other datasets. To create a geospatial data file from your 

points,  
13. Right-click on TreeData$ Events and select Data > Export Data.  You want to export 

All Features, so accept that as the default.  
 

14. Save to your WorkSpace\GPS folder, give it a name (e.g. trees.shp), select Shapefile 

format and click OK. Say Yes when asked if you want to add it as a layer.  
  

15. Right click the entire TreeData.xls layer and select Remove. 
 

16. Save your map. 

 
Part IV. Preparing the final map (optional) 

 
In this last optional section, you’ll use some of the cartographic tools in ArcMap to create a map 
with your GPS point data. 

 
It would be helpful to display some type of information about the trees on the map.   

1. Right-click on your trees shapefile and select Properties.   
 

2. Click the Labels tab.  Check the box that says Label features in this layer.  In the pull-

down menu under Text string, choose the field you want to display.  The description, 
scientific, or common name would be a good choice.  Make any changes you want to the 

font type, size, and color under Text symbol.   
 

3. Click OK.  If you are not satisfied with the placement of the labels, re-open the 

Properties dialog and select Placement properties under Other options.  You can 
create a buffer around labels, choose to display overlapping labels (or not), and assign 

priority to features or labels for label placement.   
 

4. Select the symbol you want to use for trees.  Open the Symbol selector by clicking once 

on the trees point symbol in the table of contents.  Make any changes you want to the 
symbol and click OK. 

 
5. Experiment with changing the symbology for the other layers until you are satisfied with 

your map display. 

 
6. When you are satisfied with the display, change to the Layout view by clicking on the 

layout view button at the lower left of the map window.  
 

7. In the layout view, look at the options available from the Insert menu at the top of the 

screen.  You might want to insert a Title, some explanatory Text, or other pictures or 
objects.  The North arrow, Scale bar, Neatline, and Legend choices will bring up a 

wizard or dialog box to guide you through the process of adding them to the layout view.  
From the File menu, select Page and Print Setup to adjust page size and orientation. 
Adjust size, extent, and orientation of the data frame as needed. Use these tools to 

complete your map to your satisfaction. 


