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Introduction

Address data can be applied to a variety of research questions using GIS. Once imported into a GIS, you
can spatially display the address locations and analyze the data for patterns. You can also filter/display
your address information based on certain criteria.

Before address data can be used in a GIS, they must be “geocoded”, assigning a specific point location
(e.g. latitude and longitude) to each address by comparing the descriptive elements in the address to
those in a reference data source. This tutorial will introduce some of the tools and methods available
within ArcGIS for using address data in GIS. It assumes some familiarity with GIS in general and
ArcGIS specifically.

In order to geocode addresses in ArcGIS, the following elements are needed:

Address Data: A table containing your properly formatted address information. Abbreviations
should be standardized and grammatical errors corrected. When geocoding street addresses, data
must include an address field with street number and name, and can include one or more of the
following: street prefix direction, prefix type, street type, and suffix direction. Street intersections
may also be included in the address field.

Reference Data: Primary reference data containing descriptive (address) and corresponding
spatial information for the geographic area referenced in your address data is needed. Address
data can then be matched with reference data and assigned spatial attributes (coordinates).
Secondary reference data can also be employed for geocoding “alias” place names (e.g.
hospitals, schools, parks) and alternate street names (e.g. highway numbers). Reference data can
be file based (shapefile or coverage) or within a geodatabase (GDB).

Address Locator: An address locator uses explicit methods for matching (geocoding) address
data to specified reference data based on guidelines unique to the locator style selected and any
customizations. Once an address locator is created, files containing its configured properties and
pathways to reference data are created. A “geocoding index” is created and stored in a new table.
This index, rather than the entire reference table, is used to quickly match addresses when
geocoding. If file based reference data is used, the index is stored in the same folder. If the
reference data is within a geodatabase, it is stored within the same geodatabase

Geocoding Engine: The geocoding engine consists of several files within the ArcGIS
program files that read the directions dictated by the address locator file and process the address
being searched, resulting in a location match for the address.
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Exercise 1: Creating and Formatting Address Data

In this exercise, we will work with a spreadsheet to create an address data table using Microsoft Excel. If
you were using your own data, and it wasn’t already in spreadsheet format it could be copied and pasted
into Excel from a text file.

The data files you’ll need for this exercise are located in the directory \GIS\ArcGIS_2\Geocode\ in the
Classroom Files folder (use the desktop shortcut to get there). Check to see if there is a folder named
“WorkSpace” at the top level of the C:\ drive on your computer. If no such directory exists, create one.
It’s important that there be no spaces or special characters anywhere in the path directories of your data
files, so be sure to create this directory at the top level of the C:\ drive.

» Copy the entire Geocode folder to C:\WorkSpace\ on your computer

» From your C:\WorkSpace\Geocode folder open the customers.xls file in Excel.

This spreadsheet is a list of businesses in Atlanta, with name, address, sales and business type
information. If you were working with your own data, at this point you would want to go through and
correct any spelling errors and standardize abbreviations. You should add and edit column headings as
necessary, always beginning with letters, shortening to 10 or less characters, removing spaces and
special characters and using intuitive self explanatory names. For example, for street address
information, column headings should be Street or Address, and for zipcode, Zone, Zip or Zipcode. This
will allow the address matching process to proceed more smoothly.

When creating tables for import into ArcGIS, pay particular attention to cell formatting. When
possible, each field/column should contain only one type/format of data. Many times Excel will make
assumptions based on entered values. For example, cells containing numbers may automatically be
defined as numeric and assigned default properties.

1 |ADDRESS = Z\F(': TYPE .
» SetFormatting for customers.xls 2 |1174-1176 PIEDMONT AVE NE 30309 Store
columns/ce "S i lirfia\iVCEIIIESACHTREE ST NE 30309 Ser\nceolnél
o Open the Format Cells menu for the & | [ [t [ o[t |7 [rotecen
ADDRESS column by right-clicking the 21| cotegory:
top of the column. z prins
o Inorder to avoid potential problems 11] | |Accounting General format cels have no specifc number format,
importing to ArcGIS, setexplicitly to E Fereentage
General format. This is usually is advised g | ssenn
for mixed format cells, as ArcGIS may 2l | [
interpret columns with numbers as numeric. s
Click OK 20
o The same applies for zipcodes —change to > i
General format. 3
o Setthe Sales column to Number format, z
with zero decimal places. z
o Once all edits are made, save the file and 29 pr——
close Excel. -
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Exercise 2: Creating Your Address Locator

In order to understand how an Address Locator is constructed and functions, we will briefly review the
process for creating your own. For those who desire more in depth coverage of this topic and geocoding
in general, please refer later to the ArcGIS Help Geocoding Guide Book (or online here).

Preparing an address locator is a two stage process, involving
A. Formatting and standardization of reference data, and
B. Creation of a composite address locator itself which will refer to the reference data.

About Reference Data

In order to assign spatial attributes to address data, a primary source of reference data is needed which
contains both spatial (point, line or polygon) and matching address elements. Ancillary reference data,
including tables containing alternate street names or place aliases can also be used. For the address
locator to work properly, the address elements must include the constituent elements and formatting
appropriate to the address locator style being used. Reference data can be file based (e.g. shapefile) or
from a geodatabase.

For street address geocoding, common address elements include
e prefix direction (“W. Redlands Blvd.”) and type (“Avenue B”),
Streetname
Street type
Suffix Direction
Zone

In ArcGIS, US Street address locators let you use reference data that includes an address range for each
side of a street segment, offering a means for approximating the location of a particular address within
the range. It is important to note that this method of address geocoding is indeed that, an approximation
of where that address would be expected to fall within a given street segment, based on an even
distribution of addresses across the range. US Census spatial data for streets can be used in this way. If
more precise geocoding is desired, a more accurate source of reference data like parcel boundaries may
be needed.

Formatting Reference Data

To illustrate what a reference file looks like, we will use a geodatabase source file.
» Open ArcCatalog from the Start>All Programs>ArcGIS menu.

From the left window, find the C:\WorkSpace\Geocode folder and
Open the Atlanta.mdb (personal geodatabase) file by single clicking on the plus sign to the left.

Now single click on the Streets data layer.

Y V. V V

In the right window, select the preview tab at the top, and look at both the Geography and
Table preview options by selecting from the drop down menu at the bottom. Notice that this file
contains both spatial and detailed attribute data.
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The attribute data found within the table includes columns containing left from address (L_F_ADD), left
to address (L_T_ADD), right from address (R_F_ADD), and right to address (R_T_ADD) values,
indicating address number ranges for the left and right side of each line segment. Street address
reference data containing address ranges for the street as a whole, and corresponding address locator
styles can also be used, but plotting location on a particular side of a street is not an option in that case.

Contents  Preview |Metadata]

| oBJECTID® | Shape* |L_F_ADD|L_T_ADD| R_F_ADD| R_T_ADD|PREFIX| PRE_TYPE| NAME | TYPE_| SUFFIX| ZIPL | ZIPR | CITYL | CITYR [STATE_ABBR
g 1]Poivine @00 G55 801 589 Drummond St |SW 30314 (30314 Atlarts | Alarta |GA
|| 2 Palyline 173 199 Hurter St |Sw  [30303 30303 |Atlanta |Atlants |GA
B 3 Palyline 100 128 101 129 Jores Ave (MW [30313 (30313 |Atlarta |Atlanta |GA
[ 4 Palyline 130 158 131 159 Jones Sve MW [30313 30313 |Atlarta |Atlanta |GA
B 5 Palylne |10 166 161 167 Jones sve MW [30313 30313 |Atlanta |Atlanta |GA
] 6 Polylne  |168 214 169 215 Jones Sve MW (30314 (30314 |Atlarta |Atlants |GA
B 7 Palylne  |216 282 217 263 Jones Ave MW [30314 [30314 |Atlanta |Atlanta |GA

The remaining columns of the streets table contain other address elements including prefix, street name,
type, suffix, zipcode (for each side of each street segment), city and state.

When you create an address locator, the address fields in the reference data that you use for the locator
should be standardized according to the geocoding rules used by the address locator. ArcToolbox
contains a Standardize Address tool for standardizing and parsing elements to match a particular address
locator style. Doing so will increase the geocoding match rate that you can achieve with the address
locator. If your reference data and output table (geocoded address data) are part of the same
geodatabase, you can create a dynamic output. Subsequent edits that you make to the address fields in
the input address data will then automatically be reflected in the output table. For this tutorial we will be
using preformatted/standardized reference data, so you can skip this step.

Creating an Address Locator

From the left window of ArcCatalog:
» From the C:\WorkSpace\Geocode
folder, right click the Atlanta.mdb file

Select New > Address Locator

For Address Locator Style click the E{
icon and select the US Address—Dual
Ranges. Click OK.

Browse for the Reference Data file by
clicking the folder icon.

+ [l Toolboxes

3 ﬁzﬂ Database Servers

& @ Database Connections
+ {3 GIS Servers

& @ Tracking Connections

Copy

Delete
Rename

Refresh

Ctrl+C

F2

New

R Interoperability Connect

3

|

Import
Export

Cornpact Database
Publish to ArcGIS Server...
Distributed Geodatabase

Properties...

Feature Dataset...
Feature Class...
Table...
Relationship Class...
Raster Catalog...
Raster Dataset...
Maosaic Dataset...
Schematic Dataset
Toolbox

Address Locator...

el FEF PN

Compaosite Address Locator...
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£, Create Address Locator EI@

» From the Atlanta geodatabase ek ess Lormtor S
(C:\WorkSpace\Geocode\Atlanta.mdb), find US Address - Dual Ranges B
and selectstreets. This will serve as your Reference Data —
“Primary Table” E

Reference Data Role |i|
H H H C:\Temp\Geocode \Atlanta. mdb'streets Primary Table '

» Click the Reference Data field folderilcon again CoTenp\eocodelitanta mebidtame Aot Neme Table | |
to add an “Alternate Name Table”. Find and Py
selectaltname from the Atlanta geodatabase. n

Notice that the Field Map has guessed which « ,

reference data fields correspond to each locator =

- - Field Name Alias Mame &
field. In this exercise most fields should map _ _
i _ ) Primary Table:Right State streets:STATE_ABBR.
correctly, but you may need to adjust if using other Primary Table:Left Additonal Field  <one:>
H Primary Table:Right Additional Field <Mone =
data‘ In thls Case' . Primary Table:Altmame JoinID streets: JoinlD
> Click the Alias Name space for the Primary *Alternate Name Table: JoinID altriame: ALTNAME_ID
I Alt J - ID ﬁ Id d h Alternate Name Table:Prefix Direction  altname:PRE_DIR
Tabe name oin e and choose Alternate Name Table:Prefix Type altname:PRE_TYPE
streets:JOINID. Alternate Name Table:Street Name altrame:ST_NAME =
Alternate Name Table:Suffix Type altname:ST_TYPE
Alternate Name Table:Suffix Direction  altname:SUF_DIR.

» For Alternate Name Table:JoinlD field choose . -
altname:ALTNAME_ID. Output Address Locator -
TheSE Wl" be used tO Imk the tab|eS C:'\Temp'\.Geocode'nAﬂantafmdb'n,-!\ﬁantaAddressLocamr I@|

Configuration Keyword (optional)

» Give the Address Locator a simple name (no .
spaces or special characters) indicating it as an (—c— N 2 B RS
AtlantaAddressLocator.

» Click OK.

You should see a scrolling status message indicating creation of locator is in progress. When done you
will see the locator appear in the Atlanta geodatabase.

Configuring Address Locator

Once created address locators can be configured in multiple ways, including linking to alternate lookup
tables to increase matching rates. In this exercise we will be using tables with alternate street names and
alias place names.

> Right click the new Atlanta Address Locator and select Properties
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There are a variety of settings, including thresholds for acceptable matches, intersection connectors and
address table field names. You can leave most settings at their default values, but:

> Confirm Side offsetis setto 20 Address Loctor Properties -
- Mame: WHantaAddressLocatol Input Address Fields
feet so your address points are —_— e e
I d fr h Description: Locator style for US addresses € ield containing: S recognized IF it s named:
Clearly drawn away from the .
street centerline. In some cases Reference data:
- - C:\Temp\Geocode\Atlanta. mdb'streets =
having X and Y coordinates
_g . . [ store relative path names
(longitude and latitude) in your Fikis S
H Feature ID: OBJECTID -
output table is helpful as well <Nores
R . From Left: L_F_ADD
(ChECk bOX q] |0W€I’ I’Ight Output To Left: LT ADD Spelling sensitivity: 80 ¥
F ie IdS sectio n) i From Right: AEfs Minimum candidate score: 10 o
. = Minimum match score: 85 J

To Right: R_T_ADD i
Prefix Direction: PREFIX [ Intersections
Prefix Type: PRE TvPE Connectors: & @ |and S:g:;?zg:?gg%t,u}i bya
Street Name: NAME Output Options
Suffix Direction: SUFFIX End offset: 3
Left City or Place: CITL Match if candidates tie
Right City or Place: CITYR Output Fields
Left ZIP Code: ZIPL []% and ¥ coordinates Standardized address
e T [¥] Reference data ID [[Percent along

Your address locator can also be configured to link to a Place Name Alias table. This will allow the
locator to match addresses that use place names (e.g. parks, hospitals, schools) rather than street
addresses.

> Click on the Place Name Alias Table button | Alias Table =
ko 16 s alinsos tbis 1 e Aderis [P
er) the place_aliases table in the Atlanta | - =
geodatabase. | place alases k4
> Select the Name field as the Alias field, and Az field: NAME v
make sure Street or Intersection is set to Address Fields
ADDRESS, and Zone to ZIP. Street or Intersection: [ ppress -]
» Click OK, then OK again for the main City or Placename: [{Nune} v]
Address Locator.
State: [{Nune:b v]
ZIP Code: [Hp ,]

[ aK ] [ Cancel ]
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Exercise 3: Geocoding and Mapping Your Address Data

Now that you have your address data and address locator prepared, you are ready to geocode and map

addresses.

» Open ArcMap from the globe icon
on the top toolbar of ArcCatalog. If a
Getting Started window appears, click
Cancel or close it.

» Click the yellow Add Data “plus
sign” button at the top, and select the
streets feature that we used earlier
from the Atlanta.mdb geodatabase
(from the C:\WorkSpace\Geocode\
folder).

» Click Add Data button again and
select the customers.xls file edited
earlier, choosing the customers$
table.

» Save and name your map.

Q Atlanta.mxd - ArcMap - ArcInfo

[E= Eeh )

File Edit View Bookmarks Insert Selection Geoprocessing Customize Windows Help
Deda B X0 0|$-[19725 I EERED 2
HEQMQ@IFilles [H-TI 8@ BIEHKER Bz
L] B
Table Of Contents 1% -

1818 8
p

Gojejed &

= = layers
= L CA\Temp\Geocode\Atlanta.mdb <]
= streets
_ ] =
= B3 C\Temp\Geocode\customersxls
= E= |
1

yoieas §l

LTI -

-

izl

w’r%ﬁﬂ

(= =R ] m b

Zoom in on the center of the map layou -84.348 33.758 Decimal Degrees

In order to assist us later in reviewing/rematching addresses,

» Turn on the streets layer labeling by right
clicking in the left window and selecting

Properties.

> Click the Labels tab and make sure Name is Tet s
selected as the Label field. Check the Label
Features in this Layer box in the upper left, and @ B~

click OK.

To start the geocoding process,

» Add the Geocoding toolbar-click Customize >
Toolbars > Geocoding. Drag and dock the tool ok [ Canca ] (oo

bar to the top toolbar area

-8l
General | Source | Selection [ Display | Symbology [ Fields | Definition Query | Lebels | Joins & Relates [ Time | HTML Popup |
Label features in this layer

Layer Properties

Msthod [ Label sl he features the same way. -

Al features will be Iabeled using the options specied

.

Label Field NAME

Text Symbol

AsBoYyZz
W= zu

Other Options Pre-defined Label Style

Placement Properties.. | | ScaleFRange.. | [ LabelStyles ]

A list of default locators, including geocoding services from ArcGIS Online and a Military Grid
Reference System (MGRS) locator, have been added to ArcMap. You can use these locators to

find addresses or locations.

ArcGlIS Tutorial: Geocoding Addresses (v10.0) —2011-10-21 — p.7



Q) Atlanta.mxd - ArcMap - Arclnfo
To adql our Atlanta locator, _ A B L BB xIm b
» Click Locator selectorarrow on the Geocoding Tool bar and select QRANG N €+ E-TINOFE
0% i
<Manage Address LocatorS> 10.0 Notth Amevics Geooe ] <Type an address > -
» Click Add... Navigate to C:\WorkSpace\Geocode\Atlanta.mdb, e e e e ™) |
click Add then select the AtlantaAddressLocator. 031 N At G S (el v '
- 9.3.1 Europe Geocode Service (ArcGIS Online)
> Click Add then Close Rl 4
. [cVarge Addess ocatos >}
On the Geocoding Toolbar, ST
> click the Geocode Addresses button ™ . Geocode Addresses: AtlantaAddressLocstor o
Address table:
> Select (highlight) the AtlantaAddressLocator and click (customerss ]
O K Address Input Fields
' Street or Intersection: [ADDRESS .]
» Select the customers$ table as the Address table, and Gity or Placename: [<Mone> 7
make sure the Street and Zone fields match up correctly. State: | <None> 2]
ZIP Code: [ZIP - ]

If we were using an address and reference table that were both
within the same geodatabase, we could select the Create a

Cutput
(@ Create static snapshot of table inside new feature dass

dynamic feature class related to table as an option. This would Create dynamic feature dass related to table
allow any future updates to our address data to automatically Output shapefile or festure dass: .
. . . C:A\Temp'GeocodeGeocoding_Result shp
be represented in an updated output data file (in this case a
shapefile).
’ Advanced Geometry Options...
The geocoding options were already configured when we
created the address locator so we don’t need to change them.
The Advanced Geometry options can be used to edit the o[ conce

Spatial Reference properties of the output data. Leave them at
the default values as well.

» Give your output shapefile a name and save it in your C:\WorkSpace\Geocode folder.

» Click OK to start the geocoding process.

2| Once the automated geocoding step is
= complete, a window should appear
Matched: 44 (98%) indicating how many have been matched,
] Tied: 1 (2%) and remain unmatched.
Unmatched: 0 (D%) You should see that the 45 addresses

matched successfully, however one is a

e L - | | match with candidates tied.

Completed

» Click the Rematch button to
open the Interactive Rematch
Rematch Close Addresses Dialogue box.

Average speed: 943,000 records/hour
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» From the top Show Results menu, select Matched Addresses with Candidates Tied

In this case, the address locator has successfully interpreted the intersection address, but has found two
likely candidates.

QS Interactive Rematch - Geocoding_Result EI@
Show results: Matched Addresses with Candidates Tied |L] [ Manage result sets... ] [ Refresh ] [ Rematch Automatically
B Matched: 44 (98%)
| FID | Shape | Status | Score | Match_type | B Tied: 1%)
»| 13 | Point [T [ 100 [A | Cypress St NE & 3rd St NE, Atianta, G4 30308
B Unmatched:  0(0%)

v | |

4 1

o« 1 M| (of1)

Candidate details:

Address:

Street or Intersection CYPRESS ST NE ¢

City or Placename
State
ZIF Code

2 Candidates

Score ©  Match_addr

100
100

30308

Cypress StNE & 3rd St NE, Atlanta, GA 30308 85 34
Cypress StME & 3rd 5t NE, Atlanta, GA 30308 -85

X ¥
R
R

651
701

Intersec...

34 Intersec...

Addr_type Sidel Froml Tol

699
751

F X
L
Addr_type
Side
From
To

-84.385321000
33.773603001C
Intersection
R L
851 58
893 80

PreDir
PreType
StreetMame Cypres 3rd

Close

4 n 2

H Zoom to Candidates ] @ Pick Address from Map [ Search l [ Match ] [Unmatdﬂ] Save Edits

l Geocoding Options. ..

» Click the Zoom to Candidates button to take a closer look.

You may need to move or resize the Interactive Review box to get a clear view. If needed you can right
click each Candidate in the Interactive Rematch window and select Flash to highlight.

Notice that Cypress Street does indeed appear to intersect twice
with 3" In cases like this you would need to verify by some
other means which intersection was the correct one.

Cypress

- °

» For our purposes select either from the Interactive
Rematch window and click Match. All addresses should
now be matched.

> Click Close to close the Rematch window.

Cypress

If you ever need to go back and review or rematch addresses, you can launch the Interactive Review

% .

window again using the Geocoding Toolbar Review/Rematch Addresses button
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Exercise 4: Mapping Addresses Using ArcGIS Online Geocoding Services

ESRI offers several ready to use online geocoding services through the user interface of ArcGIS
Desktop 10.

To use the ArcGIS Online Geocoding features for geocoding single addresses

» From the Geocoding Toolbar, select 10.0 North American Geocode Service.

» Inthe <Type an address...> field, enter 1600 Peachtree St NW, Atlanta GA, 30309.
» Press the Enter key after the address elements have been entered.
>

A ToolTip appears showing the full address returned by the locator, and the point location on the
map flashes.

> Right-click the address on the Geocoding toolbar and click Add Labeled Point to add the
graphic point and its label to the map.

It is important to remember that this single address locator method will not update or create a spatial file
for this address. You can right click the address from the Geocoding Toolbar and select “bookmark™ to
save a record of location and the data frame view/zoom when the bookmark was made. You can access
and zoom to (as well as create) bookmarked views though the Bookmarks menu.

Cornell patrons also have the option for using the ArcGIS Online geocoding services for “batch
geocoding” up to 1000 addresses. Though this offers less flexibility in terms of source data, this may be
sufficient for some users needs. To geocode this way, on the Geocoding Toolbar,

» Click the Geocode Addresses button @ .
» Select (highlight) the 10.0 US Streets Geocode Service and click OK.

» Select the customers$ table again as the Address table.
» Click OK
» After several seconds you should get a result with number matched and unmatched. Click close.

If you compare these results with the previous one using the AtlantaStreetLocator, you may notice a
different match rate and locations. This is due to using different reference data.

Exercise 5: Mapping Attributes (optional)

Now that you have geocoded and mapped your address points, attributes associated with them can be
queried, analyzed and labeled. If you wish to add attributes not found within your existing address
shapefile, other attributes can be joined (see Mann Library GIS tutorial Adding Attribute Data to Spatial
Datasets).

» Right click the Geocoded Result layer created in exercise 3 and select Zoom to Layer
» Right Click again and select Properties.
» Click the Symbology tab to select the type and classification desired.
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.Layer Properties @

In this examp Ie’ a Quantltles _ G raduate d ‘S(::eml I Source | Selection I Displayl Symbology | Fields | Definition Gueryl Labels I Joins & Relates | Time | HTML Papupl
— Draw guantities using symbol size to show relative values. Impart...
Symbols type of sympology has_ been _ Features - e val (gt
selected for Sales attributes (designated in Qurttes | v SAES . Naturl reaks enkc)
the Value Fields box). Symbols, classes, e o mes s o [Casy.
ranges and labels can be modified as needed | Gre ) SmeelSeelent e tE —
(labels will be represented in the Layout Smbed | Rorue tobel .
N . +  10843.400000 - 34253 2000 10843 400000 - 34253 2000
VIeW On the Iegend If addEd) @  34253.200001 - 47896.300( 34253.200001 - 47896.300(
. 47896.300001 - 67231.900( 47896.300001 - 67231.500C
C . £7231.500001 - 50015.500( 67231.500001 - 30015.5000

. 50015.500001 - 160911.000 90015.500001 - 160911.000

. !
® o ;\ [ Show class renges using feature values Advanced |

» Once you are happy with your results
click OK.

oKk || Concel | [ Appy |

You can also choose to distinguish between business types in your map. Many options exist for
representing this. If you wanted each of the business types to have a different color or symbol within the
same data layer, you could

» Use the Symbology Properties options explained above, select Categories —Unique Values.

» Select TYPE as Value Field

» Click the Add All Values button on bottom to list

= Anoth_er opti(_)n is to create a new map layer by querying, or
selecting attributes from the geocoded data layer.

Select By Attributes

Layer: |“ Geocoding Result: Geocoding_Result j
[] Only show selectable layers in this list

Method:  [Create a new selection v » From the Selection > Select by Attributes menu, this

"NAME" N window opens.

"ADDRESS"

"ZIP"

;:EES , » Inthis case, a “create new selection” query has been

constructed by selecting (double clicking) the type

Cafe’ , . .
Movie Theater field, then =, and finally Café as a unique value (click
Pestaurant Get Unique Values to display all choices).

"Service Station”
"Store”

» Click Apply, then close to make your selection.

Get Unique Values | Go To:
] R > Now right click the Geocoded data layer and
» Choose Selection > Create Layer from Selected
_ z Features. A new data layer is drawn that shows only
O] (et (ko] (koo [usmve) Cafes. You can edit the layer and its properties as
[ok ][ ey ][ Close | needed.

You can also create a separate new shapefile that only includes Cafes by right clicking, selecting
Data>Export Data>Selected Features. After selecting the location specify Shapefile as type.
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